Configure VLT between two Dell S4128T-on or S4128F-on switches

From Notes_Wiki

Home > Switch configuration notes > Configure VLT between two Dell S4128T-on or S4128F-on switches

VLT configuration

To configure VLT between two Dell S4128T-on switches use following steps:

  1. Connect to switch using console
  2. Configure management IP on OOBE management interfaces (eg 1.1.1.1 and 1.1.1.2) in below example
    1. Configure management IP on first switch
      interface mgmt1/1/1
      no shutdown
      no ip address dhcp
      ip address 1.1.1.1/30
      ipv6 address autoconfig
    2. Configure management IP on second switch
      interface mgmt1/1/1
      no shutdown
      no ip address dhcp
      ip address 1.1.1.2/30
      ipv6 address autoconfig
  3. Ensure back to back management connectivity between two switches. After that if you are connected to console of first switch, you can get access to second switch via:
    system bash
    ssh admin@10.1.1.2
  4. Assuming we will use interfaces 25 and 26 on both switches for VLT. Configure all the four interfaces (25,26 on switch1 and 25,26 on switch 2) as:
    interface ethernet1/1/25
    description VLTi
    no shutdown
    no switchport
    flowcontrol receive on
  5. Configure VLT on first switch using interfaces 25 and 26 using:
    vlt-domain 1
    backup destination 1.1.1.2
    discovery-interface ethernet1/1/25-1/1/26
    peer-routing
    primary-priority 1
  6. Configure VLT on second switch using interfaces 25 and 26 using:
    vlt-domain 1
    backup destination 1.1.1.1
    discovery-interface ethernet1/1/25-1/1/26
    peer-routing
    primary-priority 2
  7. After this the VLT status should be up which can be validated with
    show vlt 1
    Example output
    Domain ID  : 1
    Unit ID  : 1
    Role  : primary
    Version  : 3.1
    Local System MAC address  : f0:d4:e2:5f:f4:0f
    Role priority  : 1
    VLT MAC address  : f0:d4:e2:5f:f4:0f
    IP address  : fda5:74c8:b79e:1::1
    Delay-Restore timer  : 90 seconds
    Peer-Routing  : Enabled
    Peer-Routing-Timeout timer  : 0 seconds
    Multicast peer-routing timer  : 300 seconds
    VLTi Link Status
    port-channel1000  : up
    VLT Peer Unit ID System MAC Address Status IP Address Version
    ----------------------------------------------------------------------------------
    2 f0:d4:e2:5f:da:0f up fda5:74c8:b79e:1::2 3.1
  8. You can check whether back-to-back management connectivity is working properly or not using:
    show vlt 1 backup-link
    Example output
    VLT Backup Link
    ------------------------
    Destination  : 1.1.1.2
    Peer Heartbeat status  : Up
    Heartbeat interval  : 30
    Heartbeat timeout  : 90
    Destination VRF  : default
  9. Finally you can check VLT configuration is done properly or not using:
    show vlt 1 mismatch


VRRP configuration

After VLT configuration is done we can do VRRP between two switches such as:

Switch1:

config t
    interface vlan <vlan-id>
       ip address 172.17.22.61/22 
       vrrp-group <vlan-id>
          virtual-address 172.17.22.62
          exit

Switch2:

config t
    interface vlan <vlan-id>
        ip address 172.17.22.60/22 
        vrrp-group <vlan-id>
           virtual-address 172.17.22.62
           exit

By keeping VLAN-ID and vrrp-group same we can ensure that we use same vrrp-group for same VLAN and accidentally do not mix vrrp-group number for different VLANs.


Port-channel configuration

We can configure port-channel to do LACP between two switches in VLT to a remote switch (switch pair) using:

Switch1::

config t
    interface portchannel <interface-id>
        description ABCD
        switchport mode trunk
        switchport trunk allowed VLAN 1,10,100
        vlt-port-channel <interface-id>
        mtu 9216
        no shut
   interface ethernet <interface-id>
       description part of channel-group <interface-id> 
       no switchport
       channel-group <interface-id> mode active
       no shut

Similarly on Switch2::

config t
    interface portchannel <interface-id>
        description ABCD
        switchport mode trunk
        switchport trunk allowed VLAN 1,10,100
        vlt-port-channel <interface-id>
        mtu 9216
        no shut
   interface ethernet <interface-id>
       description part of channel-group <interface-id> 
       no switchport
       channel-group <interface-id> mode active
       no shut

Then see status using:

show port-channel summary



Home > Switch configuration notes > Configure VLT between two Dell S4128T-on or S4128F-on switches