Configure VLT and DCB across two Dell MXL 10/40GbE chassis switches

From Notes_Wiki

Home > Switch configuration notes > Configure VLT and DCB across two Dell MXL 10/40GbE chassis switches

Quite similar to Configure VPC between two Cisco Nexus switches, VLT can be configured across two Dell MXL 10/40GbE chassis swiches. Further since these switches support converged network adapter or FCoE, Data Center Bridging (DCB) can be configured to use 10gbps port as 2gbps network + 8gbps storage.

The configuration is explained with example for two switches A1 and A2.

Example configuration

Example configuration for A1 switch

VLT across two MXL-10/40GbE switches:

A1 - Configure hostname, required features, management IP and accounts

hostname MXL_A1_SW
!
feature fc
!
protocol lldp 
!
redundancy auto-synchronize full
!
username admin password 7 <redacted> privilege 15
username root password 7 <redacted> privilege 15 role sysadmin
!
protocol spanning-tree pvst 
 no disable 
 vlan 10,20,30 bridge-priority 61440  
!
interface ManagementEthernet 0/0
 ip address 10.0.0.1/24
 no shutdown
!
management route 0.0.0.0/0 10.0.0.3 


A1 - VLT domain configuration

Create vlt domain for integrating both switches with vlt including heartbeat via management port as backup:

vlt domain 1 
 peer-link port-channel 100
 back-up destination 10.0.0.2 
 primary-priority 1 
 delay-restore 5 
!
stack-unit 0 provision MXL-10/40GbE
!
interface fortyGigE 0/33
 no ip address
 mtu 12000
 no shutdown
!
interface fortyGigE 0/37
 no ip address
 mtu 12000
 no shutdown
!
interface Port-channel 100
 description ### VLTi Peer link Port Channel connectivity ###
 no ip address
 channel-member fortyGigE 0/33,37
 no shutdown
!


A1 - Configure Fcoe-map and DCB-map

Configure VLAN for FCoE traffic, fcoe-map and dcb-map. DCB map is configured for 2gbps network, 8gbps fc traffic per port.

interface Vlan 1002
 description FCOE_VLAN_FOR_A1
 no ip address
 no shutdown
!
fcoe-map SAN_FABRIC_A1
 fc-map 0efc02
 fabric-id 1002 vlan 1002
!
dcb-map FLEXIO_DCB_MAP_PFC_OFF
 no pfc mode on
!
dcb-map SAN_DCB_MAP
 priority-group 0 bandwidth 20 pfc off
 priority-group 1 bandwidth 80 pfc on
 priority-pgid 0 0 0 1 0 0 0 0
!


A1 - Configure host or blade internal interfaces

Configure interface to use entire 10G for network

interface TenGigabitEthernet 0/1
 description ### Connected Blade Server 1 NIC 1 ###
 no ip address
 portmode hybrid
 switchport
 spanning-tree pvst edge-port 
 no shutdown
!

Configure interface to use 2gbps for management network and 8gbps for SAN traffic:

interface TenGigabitEthernet 0/17
 description ### Connected Blade Server 1 NIC 3 ###
 no ip address
 mtu 12000
 portmode hybrid
 switchport
 spanning-tree pvst edge-port 
 fcoe-map SAN_FABRIC_A1
 dcb-map SAN_DCB_MAP
 no shutdown
!


A1 - Configure external uplink interfaces

Configure LACP of uplink 10G ports for uplink using port-channel1:

interface Port-channel 1
 description ### Uplink-to - core Switch ###
 no ip address
 portmode hybrid
 switchport
 vlt-peer-lag port-channel 1
 channel-member te 0/41 - 42
 no shutdown
!
interface TenGigabitEthernet 0/41
 no ip address
!  
 port-channel-protocol LACP 
  port-channel 1 mode active 
 no shutdown
!
interface TenGigabitEthernet 0/42
 no ip address
!  
 port-channel-protocol LACP 
  port-channel 1 mode active 
 no shutdown
!


A1 - Configure external FC ports

Configure required fiber-channel ports for SAN while leaving other ports disabled:

interface FibreChannel 0/49
 fabric SAN_FABRIC_A1
 no shutdown
!
interface FibreChannel 0/50
 fabric SAN_FABRIC_A1
 no shutdown
!
interface FibreChannel 0/51
 shutdown
!
interface FibreChannel 0/52
 shutdown
!


A1 - Configure VLANs and port-to-VLAN mapping

Configure untagged and tagged VLANs per port. VLAN 1 should be on vlt-peer link port-channel 1. All VLANs (Eg 1,10,20,30) should be part of Uplink port-channel 100.

interface Vlan 1
 no ip address
!untagged TenGigabitEthernet 0/1-32
!untagged Port-channel 1,100
 no shutdown
!
interface Vlan 10
 no ip address
 tagged TenGigabitEthernet 0/1-8
 tagged Port-channel 1
 no shutdown
!
interface Vlan 20
 no ip address
 tagged TenGigabitEthernet 0/1-8
 tagged Port-channel 1
 no shutdown
!
interface Vlan 30
 no ip address
 tagged TenGigabitEthernet 0/1-8
 tagged Port-channel 1
 no shutdown
!


A1 - Configure console password

Set console password and disable timeout, if required:

line console 0
 password 7 888dc89d1f1bca2882895c1658f993e7
 exec-timeout 0 0


Example configuration for A2 switch

VLT across two MXL-10/40GbE switches:

A2 - Configure hostname, required features, management IP and accounts

hostname MXL_A2_SW
!
feature fc
!
protocol lldp 
!
redundancy auto-synchronize full
!
username admin password 7 <redacted> privilege 15
username root password 7 <redacted> privilege 15 role sysadmin
!
protocol spanning-tree pvst 
 no disable 
 vlan 10,20,30 bridge-priority 61440  
!
interface ManagementEthernet 0/0
 ip address 10.0.0.2/24
 no shutdown
!
management route 0.0.0.0/0 10.0.0.3 


A2 - VLT domain configuration

Create vlt domain for integrating both switches with vlt including heartbeat via management port as backup:

vlt domain 1 
 peer-link port-channel 100
 back-up destination 10.0.0.1 
 primary-priority 1 
 delay-restore 5 
!
stack-unit 0 provision MXL-10/40GbE
!
interface fortyGigE 0/33
 no ip address
 mtu 12000
 no shutdown
!
interface fortyGigE 0/37
 no ip address
 mtu 12000
 no shutdown
!
interface Port-channel 100
 description ### VLTi Peer link Port Channel connectivity ###
 no ip address
 channel-member fortyGigE 0/33,37
 no shutdown
!


A2 - Configure Fcoe-map and DCB-map

Configure VLAN for FCoE traffic, fcoe-map and dcb-map. DCB map is configured for 2gbps network, 8gbps fc traffic per port.

interface Vlan 1003
 description FCOE_VLAN_FOR_A2
 no ip address
 no shutdown
!
fcoe-map SAN_FABRIC_A2
 fc-map 0efc03
 fabric-id 1003 vlan 1003
!
dcb-map FLEXIO_DCB_MAP_PFC_OFF
 no pfc mode on
!
dcb-map SAN_DCB_MAP
 priority-group 0 bandwidth 20 pfc off
 priority-group 1 bandwidth 80 pfc on
 priority-pgid 0 0 0 1 0 0 0 0
!


A2 - Configure host or blade internal interfaces

Configure interface to use entire 10G for network

interface TenGigabitEthernet 0/1
 description ### Connected Blade Server 1 NIC 2 ###
 no ip address
 portmode hybrid
 switchport
 spanning-tree pvst edge-port 
 no shutdown
!

Configure interface to use 2gbps for management network and 8gbps for SAN traffic:

interface TenGigabitEthernet 0/17
 description ### Connected Blade Server 1 NIC 4 ###
 no ip address
 mtu 12000
 portmode hybrid
 switchport
 spanning-tree pvst edge-port 
 fcoe-map SAN_FABRIC_A2
 dcb-map SAN_DCB_MAP
 no shutdown
!


A2 - Configure external uplink interfaces

Configure LACP of uplink 10G ports for uplink using port-channel1:

interface Port-channel 1
 description ### Uplink-to - core Switch ###
 no ip address
 portmode hybrid
 switchport
 vlt-peer-lag port-channel 1
 channel-member te 0/41 - 42
 no shutdown
!
interface TenGigabitEthernet 0/41
 no ip address
!  
 port-channel-protocol LACP 
  port-channel 1 mode active 
 no shutdown
!
interface TenGigabitEthernet 0/42
 no ip address
!  
 port-channel-protocol LACP 
  port-channel 1 mode active 
 no shutdown
!


A2 - Configure external FC ports

Configure required fiber-channel ports for SAN while leaving other ports disabled:

interface FibreChannel 0/49
 fabric SAN_FABRIC_A2
 no shutdown
!
interface FibreChannel 0/50
 fabric SAN_FABRIC_A2
 no shutdown
!
interface FibreChannel 0/51
 shutdown
!
interface FibreChannel 0/52
 shutdown
!


A2 - Configure VLANs and port-to-VLAN mapping

Configure untagged and tagged VLANs per port. VLAN 1 should be on vlt-peer link port-channel 1. All VLANs (Eg 1,10,20,30) should be part of Uplink port-channel 100.

interface Vlan 1
 no ip address
!untagged TenGigabitEthernet 0/1-32
!untagged Port-channel 1,100
 no shutdown
!
interface Vlan 10
 no ip address
 tagged TenGigabitEthernet 0/1-8
 tagged Port-channel 1
 no shutdown
!
interface Vlan 20
 no ip address
 tagged TenGigabitEthernet 0/1-8
 tagged Port-channel 1
 no shutdown
!
interface Vlan 30
 no ip address
 tagged TenGigabitEthernet 0/1-8
 tagged Port-channel 1
 no shutdown
!


A2 - Configure console password

Set console password and disable timeout, if required:

line console 0
 password 7 888dc89d1f1bca2882895c1658f993e7
 exec-timeout 0 0



Other useful commands

Other useful commands related to VLT:

show vlt brief 
show vlt detail 
show vlt role 
show running-config vlt 
show vlt statistics 
show vlt backup-link

Other useful command related to FCoE operation:

show npiv devices
show fcoe-map
show fc switch


Home > Switch configuration notes > Configure VLT and DCB across two Dell MXL 10/40GbE chassis switches